Symptoms:


After successful installation, the machine is offline in the Backup management console.



Possible causes


  • Managed Machine Service is not running.
  • A connectivity issue between the backup agent and cloud servers.
  • Registry keys "MMSCurrentMachineID" and "InstanceID" do not match with IDs on the management server in Acronis cloud.

Solution 1


Windows: navigate to Windows services and check whether the Managed Machine Service is running: 


Start -> Search ->services.msc



Look for the acronis managed machine service, restart it.


Linux: open Terminal and execute under a superuser/root /etc/init.d/acronis_mms status, restart the service 


#/etc/init.d/acronis_mms restart

Solution 2


Windows: use the Connection Verification Tool to check network connectivity. The tools can be obtained from 

https://kb.acronis.com/content/47678


Linux: open Terminal and check whether required firewall ports (80, 443, 8443,7770-7800 and 44445) are 

opened with the netcat command, for example:


nc -zv backup.exabytes.my 443

Solution 3

1. Open the backup management console, select the machine by clicking on it and check browser's address bar.



2. Note InstanceID and MMSCurrentMachineID. GUID between "phm." and "%40" is InstanceID, after "%40" is

 MMSCurrentMachineID:

    


3. Compare the values to the values on the machine:


Windows: navigate to HKEY_LOCAL_MACHINE\Software\Acronis\BackupAndRecovery\Settings\MachineManager and note the values of "MMSCurrentMachineID" and "InstanceID".
For example:
"InstanceID"="480D99EA-A79E-4FF0-9AF2-CDB6DD1D09CD" 
"MMSCurrentMachineID"="6D4FDB37-5DE0-43BF-A499-B5076B44E1F6"
If they don't match, change to registy values on the Agent machine to the ones you found in step 2.

Linux: open /etc/Acronis/BackupAndRecovery.config and note the values of "MMSCurrentMachineID" and "InstanceID".
For example:
<value name="InstanceID" type="TString">
 "C6C54E65-D328-4B2F-ABB4-37BA50E98CAA"
 </value>
...
<value name="MMSCurrentMachineID" type="TString">
 "B7B3DD56-2F64-4CF2-AB82-FA1D440730F8"
 </value>

If they don't match, change to registy values on the Agent machine to the ones you found in step 2.